• Welcome to Computer Association of SIUE - Forums.

FreeBSD install problem

Started by The_ME, 2005-02-15T23:18:24-06:00 (Tuesday)

Previous topic - Next topic


I am trying this FreeBSD as you say.
It quickly states zf_read: fill error
It then continues to the install start page

Mounting root from ufs:/dev/md0
spec_getpages:(md0) I/O read failure: (error=5) bp 0xc2d8ad74 vp 0xc170fd68
     size: 2560, resid: 2560, a_count: 2244, valid 0x0
     nread: 0, reqpage: 0, pindex: 499, pcount: 1
vm-fault: pager read error, pid 1 (swapper)
init died (signal 6, exit 0)
panic: going nowhere without my init!
Uptime: 3s
Cannot dump. No dump device defined.

Then the automatic reboot thing happens. I have tried three different hardrives. Help please.


what kind of partitions do you have setup?

do you have raid setup because it's trying to mount your root to a raid partition, which it seems to be having a problem with.
Bryan Grubaugh
Quickly aging alumni with too much time on his hands
Business Systems Analyst, Scripps Networks.


I am pretty sure I don't have any partitions setup. What settings should I have the hard drive set? Should I have it set to master or none?

William Grim


I recall the other day you thought your RAM may be bad...

The md0 device is a memory device that uses the RAM as a temporary hard drive until the OS is running.  Also, you're getting a vm-fault, meaning your virtual memory subsystem died (due to the md0 error).

Okay, so, this does look like it may be a very odd hardware incompatibility or an actual hardware problem, but you said you knew the RAM was fine?  Perhaps the RAM doesn't work on that particular mobo?

I'm just taking stabs at those ideas.  It makes sense on why you can't dump the kernel image now.

I don't know why it has that problem, but I can forward it to people who know more about it.  What type of RAM and mobo are you using (brands, models, etc)?
William Grim
IT Associate, Morgan Stanley


The RAM I was refering to was from a different computer. I was trying to increase the amount on the current computer.

I will try the install on the other computer which I have been using for parts. It is compaq so I think there should be the less chance of odd hardware problems.

Doesn't a memtest86 disk check RAM? Is there such a program to check RAM?

What should I have the hard drive set to master, slave, ...?

I'll check the hardware when I get home tonight.


To minimize the variables that could be making FreeBSD crash disconnect everything not needed.  (Yank out all the cards except the video card from the comp.)  Connect only one hard-drive on Master.  Also take out all but one stick of ram.  (I'm assuming you have DIMMs)  Try it and see what happens.  If you still get the error replace the one stick of RAM with a different stick and see what happens.  It should work unless something on your MOBO is bad.  To figure out what piece of hardware is bad add your extra ram back one stick at a time and boot it up seeing if you get an error, then shove the cards in there one card at a time and see which piece of hardware causes the error to occur.

My guess is that it will be a stick of ram that has gone bad.

What are the specs of your comp?


I'll try that when I get home tonight.

The computer only has one 64 Mb stick of RAM. It is a pentium. One 3com pci ethernet card, one modem (have not looked at the speed. I will be using the 2.2 gig western digigtal hard drive set to master.

If that doesnt' work, I will try the old compaq. Then I think I'll report back.


I tried installing to the compaq. Holy jusnk is the install way better than NetBSD. I only got to the where would you like to install from part though. I am going to do a FTP install. I hate to sound like the mimbo, but what do I use for my domain and such. My ISP is SBC. They use DCHP.

I think the problem may have been with the boot floppies I was using. I was having a slight problem with the compaq. I made a new boot.flp disk and no problems.


Did you set it up to use DHCP?  It should self populate the domain name field and such so long as it's working.